Newbie z3 3.0

Details of how to register as a zroadster.net user, plus tips on day-to-day usage

Moderator: Gazza

Post Reply
Rob_v6
Joined: Wed 20 Apr, 2016 20:44
Posts: 19

  Not specified

Newbie z3 3.0

Post by Rob_v6 » Sat 30 Jul, 2016 18:09

So after a bit of searching I final purchased a forum car from grandadg90 (Rahail). The car is in excellent condition with a comprehensive history.

The drive home earlier from West Yorkshire was great and the car drives spot on. Unfortunately after returning to the car after a 2 hour drive the DSC and brake light combo is on. Having read a few articles it seems a fairly common fault? The car is driving fine etc and tyre pressures are all good.

I haven't had chance to look into it a huge amount yet so may have to take it to a garage for some advice. I have read the speed sensors can become dirty? Are these easy to locate?

Thanks
Rob
Last edited by Rob_v6 on Sun 11 Dec, 2016 10:34, edited 1 time in total.

Del
Joined: Sat 19 Nov, 2011 18:35
Posts: 2119

  Z3 roadster 1.9

Re: Newbie z3 3.0

Post by Del » Sat 30 Jul, 2016 19:48

Has it had new rear brake discs/pads fitted recently? In my experience the back ones can take ages to bed in properly and just slightly uneven contact across the axle can cause this.

Rob_v6
Joined: Wed 20 Apr, 2016 20:44
Posts: 19

  Not specified

Re: Newbie z3 3.0

Post by Rob_v6 » Sat 30 Jul, 2016 20:36

Hmm interesting Del, I know Rahail had new pads fitted recently so will check to see if they were the front or rear as this could explain it. It drives absolutely fine so no immediate concerns and I can pop and hook it up to a friends diagnostics to see any error codes. I just don't want to replace parts if it's a temporary glitch.

Rob_v6
Joined: Wed 20 Apr, 2016 20:44
Posts: 19

  Not specified

Re: Newbie z3 3.0

Post by Rob_v6 » Sun 31 Jul, 2016 13:47

Interestingly we have been for a quick blast today, returned to the car and the lights are back out.

I have a feeling it could be the new brake pads bedding in and / or brake dust messing with the sensors. Let's hope they stay out now :). Cracking day for a blast down to the country pub though, hood down etc.

Del
Joined: Sat 19 Nov, 2011 18:35
Posts: 2119

  Z3 roadster 1.9

Re: Newbie z3 3.0

Post by Del » Sun 31 Jul, 2016 17:09

My experience was when fitting new Brembo discs and Textar pads all round (both premium brands). The discs, like several other makes, had the anti-rust coating which quickly scratches off where the pads make contact. The fronts seemed to create an even scratch pattern across the discs very quickly. However, the rears did not. The rear scratch pattern started as a thinner section of the top of the disc and gradually (over around 2-3 weeks of regular use) spread down the disc to create a normal pad-contact scratch pattern – one wheel seemingly getting there slightly before the other. The callipers were not in the slightest bit seized and the system contained nice clean Castrol brake fluid. During this period my ASC light was coming on for periods but when the rear brake bedding-in was complete, it went out and remained out. :shrug

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests