Air Conditioning Cable

UK forum for general and technical discussion about the Z3 roadster

Moderator: Gazza

Post Reply
Wolverine_1999
Joined: Mon 15 Feb, 2010 20:07
Posts: 454

  Z3 roadster 2.0
Location: Munich

Air Conditioning Cable

Post by Wolverine_1999 » Thu 23 Jan, 2014 21:02

Hi All,

I just bought the air conditioning switch from another forum member which arrived safe and sound :)

The cable was also sent with the switch just in case I didnt have it already... and it seems like after looking, that it is not in the car. I dont have A/C in my car but am just trying to "fill the gap" basically, but would like for it to light up of course.

Here is a picture of the cable:

Image

and here we can see the back of the connector:

Image

It is possible to see the numbers 1-8 on the switch. Which ones are used for power i.e lighting up the buttons? Are the buttons lit when the lights are on, or only after one is pressed?

Also, these are the remaining connectors behind the centre console which are not connected. Can anyone tell me which is used for what?

Image

User avatar
Southernboy
Joined: Thu 07 Oct, 2010 13:39
Posts: 6312

  Z3 roadster 3.0i
Location: Johannesburg

Re: Air Conditioning Cable

Post by Southernboy » Fri 24 Jan, 2014 08:05

I find it very odd that you say you do not have a connection for the AC. It is strange because these cars all have a standard electrical wiring loom. Have you removed the center console to have a look behind there ? If it wasn't fitted with AC at manufacture, the connection is normally tied to the main wiring loom out of the way. It doesn't make sense that a "special" wiring loom will be made just for cars with no AC. These things are "mass produced" and as such it breaks the pattern of production to make a product slightly different from standard. ie. it is cheaper to make them all the same vs have a stop start in a production line. I'm sure if you removed your center console, you will find the connector tied away there. Things like AC and Cruise Control etc were "options" so the loom must be there... :wink:
"Normal is overrated"
Image

Z3 Upgrades and Additions

User avatar
Brian H
zroadster sponsor
Joined: Tue 16 Dec, 2008 19:55
Posts: 2502

  Z3 roadster 3.0i

Re: Air Conditioning Cable

Post by Brian H » Fri 24 Jan, 2014 17:11

Wolverine_1999 wrote:Also, these are the remaining connectors behind the centre console which are not connected. Can anyone tell me which is used for what?
What were/are the standard switches in your car?

User avatar
Robert T
Site Admin
Joined: Mon 12 Jun, 2006 11:35
Posts: 9999

  Z3 roadster 1.9
Location: Cheshire

Re: Air Conditioning Cable

Post by Robert T » Fri 24 Jan, 2014 17:30

I'm looking at that and thinking you've split the switch in two and not just removed the connector from the back of it. Look at the colours of the wires in the fragment of loom that came with the switch. Do any of the connectors in your wiring loom have the same colours? The white one in the bottom right of your last picture looks like it might?

Cheers R.
Arctic Silver '99 Z3 1.9 & Black '59 Frogeye 1275cc
Image

Wolverine_1999
Joined: Mon 15 Feb, 2010 20:07
Posts: 454

  Z3 roadster 2.0
Location: Munich

Re: Air Conditioning Cable

Post by Wolverine_1999 » Fri 24 Jan, 2014 20:53

Nah doesnt work unfortunately..

I found a wiring diagram for the electrical switch and have just connected the positive and negative for each button so it lights up :D And it works :D

Looks like a car which didnt come standard with A/C wont have the cable loom in there..

What about the other connectors? Any idea what they are?

DAVE P
Joined: Fri 13 Aug, 2010 18:39
Posts: 44

  M coupe S50
Location: STOCKPORT

Re: Air Conditioning Cable

Post by DAVE P » Fri 24 Jan, 2014 20:57

The later air con switch doesn't light up like the other switches but the buttons themselves light when pressed (if that makes sense)

User avatar
Robert T
Site Admin
Joined: Mon 12 Jun, 2006 11:35
Posts: 9999

  Z3 roadster 1.9
Location: Cheshire

Re: Air Conditioning Cable

Post by Robert T » Fri 24 Jan, 2014 21:11

When you say it doesn't work, what do you mean? You found a connector that fits and it doesn't light up? If so the likelihood is that the OTHER end is not connected to anything! There are additional relays needed to install aircon and probably fuses as well.

Cheers R.

Sent from my Galaxy SII using Tapatalk 2
Arctic Silver '99 Z3 1.9 & Black '59 Frogeye 1275cc
Image

Wolverine_1999
Joined: Mon 15 Feb, 2010 20:07
Posts: 454

  Z3 roadster 2.0
Location: Munich

Re: Air Conditioning Cable

Post by Wolverine_1999 » Fri 24 Jan, 2014 21:46

No I meant those plugs shown in the picture do not fit the switch.

From the cable that came with the switch, I just took the plus and minus to hook up the lights. They light up now even though they are not pressed :)

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests