Help! Wipers stopping when stationary

UK forum for general and technical discussion about the Z3 roadster

Moderator: Gazza

Post Reply
Belle
Joined: Thu 22 Jul, 2010 20:17
Posts: 74

  Z3 roadster 1.8
Location: Glasgow

Help! Wipers stopping when stationary

Post by Belle » Sun 19 Mar, 2017 09:38

Hi,
I've searched the forum and knowledge base for help with this but haven't found anything. Hoping someone recognises the fault or can point me in the direction of a suitable thread.

While driving home last night in the rain we stopped due to motorway roadworks. It was only my boyfriend's second time driving zeddy (as I'd had a few wines) and he stalled as usually drives an automatic. When we started making way again the car was fine but the next time we stopped the wipers stopped and would not restart in any setting. We managed to pull off the motorway safely and after turning ignition off and on again the wipers seemed to be working normally but his happened every time we were stationary on the way home. Not sure if the stalling caused the problem or just a red herring. Each time the wipers stopped in the off position.

I suspect a wiper switch or relay problem but has anyone had the same thing happen? Is it an easy fix?

Thanks,

Belle

User avatar
Devon Z
Z Register member
Joined: Thu 20 Nov, 2003 21:39
Posts: 650

  Z3 roadster 2.0
Location: Brixham, Devon

Re: Help! Wipers stopping when stationary

Post by Devon Z » Sun 19 Mar, 2017 10:41

To be honest mines not been out in the rain for quite a while but I do remember that the wipers stopped when stationary, but I think they then went onto intermittent? But I could still switch them to other settings. Was a bit disconcerting at first.
If anything is at fault I would say it's the relay, that's what does the timing.
99 Topaz Individual

John Wilson
Joined: Fri 12 Jun, 2009 13:11
Posts: 240

  Z3 roadster 2.0
Location: Diss

Re: Help! Wipers stopping when stationary

Post by John Wilson » Sun 19 Mar, 2017 12:18

I think your boyfriend is just making a meal of it so that next time out, you'll be driving and he can have a few drinks. My wipers stop at traffic lights, by the way.

alec.m
Joined: Tue 05 Oct, 2010 20:01
Posts: 533

  Z3 roadster 2.8
Location: Lymington

Re: Help! Wipers stopping when stationary

Post by alec.m » Sun 19 Mar, 2017 14:10

I think it`s designed to go to stop/intermittent when you come to a halt. I`m on my second Z and they both do this.

User avatar
motco
Joined: Tue 18 Aug, 2009 19:12
Posts: 634

  Z3 roadster 2.2i

Re: Help! Wipers stopping when stationary

Post by motco » Sun 19 Mar, 2017 14:24

TADTS, or TADTM in your case. 'They all do that sir/madam'. But they do usually start again as you drive off.

User avatar
pingu
Joined: Fri 30 Apr, 2004 17:01
Posts: 3337

  M roadster S50

Re: Help! Wipers stopping when stationary

Post by pingu » Sun 19 Mar, 2017 15:16

Assuming that you didn't play with the stalk, they should have started again when you drove off.

You said that they wouldn't go again when you restarted, no matter what you did with the stalk.

There could be several causes for this. It is not a simple circuit as BMW thought it would be a good idea to complicate a simple circuit by adding a wiper control module. It's at times like this that you wish you had RobertT's Frogeye :) .

Wiper motor kapput.

Stalk controls kapput.

Wiper/Washer module kapput or things/connections that go to or from it...light switch, instrument cluster (speed output), headlight washers, wiper motor, washer pump, wash/wipe controls.

Fuse 3 kapput.

Fuse 36 kapput.

Fuse 37 kapput. Unlikely, as it also covers other things that you haven't mentioned.

Fuse 44 kapput. Unlikely, as it also covers other things that you haven't mentioned.

Earth connections to any of the components. Unlikely, as the earth connections are shared with other components.

Any of the associated wires.


If you put the build year in you profile, that can also help with diagnosis. I have guessed that it is 1998.
Pingu

User avatar
Robert T
Site Admin
Joined: Mon 12 Jun, 2006 11:35
Posts: 9984

  Z3 roadster 1.9
Location: Cheshire

Re: Help! Wipers stopping when stationary

Post by Robert T » Sun 19 Mar, 2017 17:54

pingu wrote:It's at times like this that you wish you had RobertT's Frogeye.
Hmmm. The wiring might be simpler, but they don't self-park, intermittent involves operating them for a single wipe manually and the drive cable periodically needs re-greasing!

Regarding the Z3 wipers, mine has an intermittent fault related to the speed signal. This is what tells the wipers to go intermittent when you stop, and restart normal wipe when you set off. It also controls the volume automatically on some stereos as you go faster. Mine periodically has a dicky fit with the wipers doing several wipes, then reverting to intermittent whilst the car is stationary. It also makes the stereo play louder randomly. There is clearly a wiring fault somewhere, but I haven't found it yet. Your problem could be related to mine by the sound of it.

Cheers R.

Edit: Auto-correct fails corrected... :roll:

Sent from my SM-G920F using Tapatalk
Arctic Silver '99 Z3 1.9 & Black '59 Frogeye 1275cc
Image

Belle
Joined: Thu 22 Jul, 2010 20:17
Posts: 74

  Z3 roadster 1.8
Location: Glasgow

Re: Help! Wipers stopping when stationary

Post by Belle » Sun 19 Mar, 2017 21:37

Thanks for your replies John, Alec and motco but I have had my Z3 for 7 years and am well aware that the wipers slow down when idling at lights. I maybe wasn't clear enough that the issue was that they stopped completely when idling and did not resume when we moved off. They only restarted when the ignition was switched off and we moved off quickly. The same thing then proceeded to happen a further four times on the way home which was pretty disconcerting on a dark and stormy night.

Other info that might be helpful.
It is a 1998 1.9L
All other equipment, blowers, lights were working properly.

I will check out the fuses pingu but the fact that everything working okay once ignition restarted is confusing me.
I've never noticed the stereo getting louder robert but that would be cool. I've got zeddy in drying out in the garage and will see how things are next time I'm out in the rain.

Belle

therealdb1
Joined: Tue 25 Jun, 2013 22:47
Posts: 232

  Z3 roadster 2.0

Re: Help! Wipers stopping when stationary

Post by therealdb1 » Mon 20 Mar, 2017 00:19

Pingu has given a comprehensive check list but it sounds like there could be an issue with the wiper module WWM as presumably it resets itself when the ignition is switched on. I cannot see much on the circuit diagram that would not reveal itself somewhere else if it was to be faulty.
You would expect the fault not to be reproducible if there were some other problem but definitely check the simple things first.

User avatar
Robert T
Site Admin
Joined: Mon 12 Jun, 2006 11:35
Posts: 9984

  Z3 roadster 1.9
Location: Cheshire

Re: Help! Wipers stopping when stationary

Post by Robert T » Mon 20 Mar, 2017 12:55

I also have another problem with my car, which may be related. Once in a blue moon, all the dials on the instrument cluster stop working - the rest of the cluster works fine - turn it off and wait long enough for the immobiliser to cut in and it will work fine again. My theory is that a chafed wire causes a short, and the cluster partially shuts down to protect itself. It doesn't reset until the power is taken away completely (hence having to wait for the immobiliser). How does this relate to my other problem with the speed signal? Well I believe (from the wiring diagram) that the speed signal for the stereo and wipers is taken from the instrument cluster. I am wondering if this is related to you problem in that the speed signal is so out of range that the wiper module shuts down, or whether the wiper module has a bad connection somewhere and shuts itself down when the car-not-moving intermittent wipe kicks in. If you have a chunk of harness which is chafed, then it depends which wires are exposed and what they short to as to what symptoms you will get.

Cheers R.
Arctic Silver '99 Z3 1.9 & Black '59 Frogeye 1275cc
Image

Belle
Joined: Thu 22 Jul, 2010 20:17
Posts: 74

  Z3 roadster 1.8
Location: Glasgow

Re: Help! Wipers stopping when stationary

Post by Belle » Mon 20 Mar, 2017 21:25

It could be something like that Robert.
My other car is a T4 van and the only problems I've had with it have been chafed wiring for the horn and throttle. I'll see if I can identify the wiring and module when I next have some free time. :bawl:

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests