Abs / traction light

UK forum for general and technical discussion about the Z3 roadster

Moderator: Gazza

Post Reply
Hdz3
Joined: Thu 03 Dec, 2015 17:17
Posts: 17

  blank

Abs / traction light

Post by Hdz3 » Sun 08 Oct, 2017 15:46

Hi, just had two New front tyres on my z3 , and a day or two later the abs/traction light has come on , before it came on the abs started working when braking at low speed , check tyres both the same size.circuit board was repaired two years ago .

peter2b
Joined: Sat 01 Nov, 2014 18:47
Posts: 949

  Z3 roadster 2.2i
Location: cheshire

Re: Abs / traction light

Post by peter2b » Sun 08 Oct, 2017 20:22

I had new front tyres fitted a couple of months ago but only get the abs light to come(red light with a triangle in it) on when I pull away on muddy or wet roads
peterz3

wifevanda
Joined: Mon 09 Aug, 2010 20:36
Posts: 51

  Z3 roadster 2.0
Location: dagenham

Re: Abs / traction light

Post by wifevanda » Mon 09 Oct, 2017 21:21

Hi changed my absence module a year ago .Been OK now playing up again .anyone got a link to just get the module overhauled .

wifevanda
Joined: Mon 09 Aug, 2010 20:36
Posts: 51

  Z3 roadster 2.0
Location: dagenham

Re: Abs / traction light

Post by wifevanda » Mon 09 Oct, 2017 21:24

wifevanda wrote:
Mon 09 Oct, 2017 21:21
Hi changed my abs module a year ago .Been OK now playing up again .anyone got a link to just get the module overhauled .

Hdz3
Joined: Thu 03 Dec, 2015 17:17
Posts: 17

  blank

Re: Abs / traction light

Post by Hdz3 » Wed 11 Oct, 2017 19:05

Checked tyre pressures, a little high dropped them to 29 , lights still on.

User avatar
Robert T
Site Admin
Joined: Mon 12 Jun, 2006 11:35
Posts: 9998

  Z3 roadster 1.9
Location: Cheshire

Re: Abs / traction light

Post by Robert T » Wed 11 Oct, 2017 20:17

Get the codes read and find out whether it is a wheel sensor or the pump/control board. Having the wheels off may have disturbed some dirt, or the wiring, but unless you read the codes, you won't know which wheel to check.

Cheers R.
Arctic Silver '99 Z3 1.9 & Black '59 Frogeye 1275cc
Image

alec.m
Joined: Tue 05 Oct, 2010 20:01
Posts: 535

  Z3 roadster 2.8
Location: Lymington

Re: Abs / traction light

Post by alec.m » Thu 12 Oct, 2017 17:14

Check the wire to the wheel sensor. I had new brake pads fitted a couple of years ago and somehow the wire came loose, rubbed on something and the insulation wore away and it periodically earthed itself and that lit up the ABS light.

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests