Seat motors

Repository of 'how to do' articles relating to the Z3 and M roadster/coupe

Moderator: Gazza

Post Reply
User avatar
Southernboy
Joined: Thu 07 Oct, 2010 13:39
Posts: 6408

  Z3 roadster 3.0i
Location: Johannesburg

Seat motors

Post by Southernboy » Sat 27 Oct, 2018 14:15

Yesterday the driver side seat height adjustment motor stopped working.
After removing the seat mounting bolts and the safety belt bolt I tilted the seat inside the car so it was bridged with the backrest on the center console and the base resting on the door sill. I place a towel under both parts where the seat was resting. I left the yellow tensioner connection intact so that I could have power at all times without inducing an airbag warning light on the cluster which would then require clearing.
I disconnected the main power supply to the seat switch and tested the switch using a multimeter and by toggling the switch it was apparent that it was working as it should.
Next, I checked for a circuit in the height adjustment motor with the multimeter and got a negative response. I checked the fwd/back motor and the multimeter indicated a circuit in that motor.
So the problem was in the electric motor. It is held between 2 metal struts under the seat and by 3 torx 20 self tapping screws at each end which pass through the metal struts and screw into the plastic end caps of the motor. Once these are removed, the motor can be jiggled out completely. At the one end it has a soft plastic tube in which the little flexible drive shaft is housed and which goes to the mechanical gearbox which then drives the threaded rod that activates the lifting mechanism. When I removed the motor, the flexible drive shaft remained attached into the gearbox.
Next I stripped the motor after using a generous amount of switch cleaner sprayed into the motor, but which did nothing to create a circuit when checked.
Stripping the motor is easy. A narrow screwdriver is required to carefully pry up the 4 tabs at either end which hold the end caps in position. Place the screw driver into the slot at the tip of the tab and lever it upwards just sufficient to allow comfortable clearance of the plastic cap.
When replacing the caps, note that there is a "key" tab in the plastic cap which determines it's orientation when fitted. If these are not on the correct side, the caps will not seat into the motor body.
Once the tabs have been lifted, you can remove the end caps. There are no hidden surprises like clips, springs etc that might fly out and cause issues in re-assembly.
Once removed you will notice the end cap where the power goes in are connected to the 2 motor brushes, These are on springs, and are the only difficult part of re-assembly - I'll get to that at the end to explain easy re=assembly.
The armature is now left inside the motor body and is being held in there by the powerful field coil magnets stuck to the inner face of the motor body - they don't and possibly can't be removed without damage, so eave them alone.
Pulling the armature out the body is surprisingly difficult because those magnets are very strong, but with a little pull on one end and a thumb push from the other end, it will pop out - if unwillingly to the last. It isn't a tight fit , it's just pure magnetic force holding it in there. In fact if you get it 1/2 way out and release it, it will shoot back down the tube in a flash.
I used a small piece of 2500 grit wet paper to polish the copper split ring which the brushes ride on. This removed a negligible layer of copper, and left it super smooth and clean all round. I used the multimeter to check that each pole had a circuit with every other one. This is done by using one wire of the mete on one copper pole, and then touching the other meter wire on all the other poles. You only need check from one pole to all the others.
Next I used the same 2500 paper folded in 1/2 and ran it in the little grooves between each of the split ring poles to clean out any debris that might be lodged there and which might cause a short circuit between adjacent poles.
You might see some pretty alarming gouge marks on the circumference of the iron core of the armature - ignore them. They were made at the time of manufacture to balance the armature and don't represent any kind of damage or wear.
I then cleaned the end cap where the brushes are housed by using switch cleaner and a cotton ear bud. The other end cap is just that, an end cap with a brass bush to hold the armature. If you examine the armature bushes in both end caps you will note they are movable - much like the eye of a chameleon. That's the way they should be, so don't be alarmed.
Finally I sprayed the armature with switch cleaner to remove any residue etc from my sand papering and allowed it to dry. I used a very little grease to rub directly onto the armature shaft at each end where it fits into the end cap bushes.
Re-assembly.
There is only one way to do this ( I tried all the others, and it just doesn't allow ease of assembly, so I assume this is the way it was done at manufacture).
You need to fit the armature to the "wired" end cap first. That's where the 2 brushes are. The brushes, being sprung won't allow the split ring to pass between them. At this point, you must pull the white plastic brush housing part out of the end cap. It will only come out about 20 - 25mm. It cannot be completely removed.
Before you attempt re-assembly, pull that part out and then push it in to satisfy yourself that you are aware of where it catches as you push it back in.
So with the brush holder pulled out as far as it will safely go, angle the armature so that one brush passes over the copper split ring. Now push the armature so that it fully compresses that brush into it's little square tube, and you can get the split ring past the other brush. Now make sure the plastic housing goes back in and the armature shaft lodges into its bush at the top of the end cap.
Remember I said the armature will pop back into the motor body in a flash because of the magnetic force - well now you have to keep the end cap you have just fitted to the armature in position while you fit the armature back into the motor body. This is best done by inserting a finger from the opposite end, through the motor body and placing the armature shaft on the tip of that finger. Now carefully lower the armature into the body whilst pushing down on the brush end cap with your free hand. If you place the brush en cap in the palm of your hand and using your fingers to grasp the armature you can safely keep the armature from disappearing into the motor body and leaving you holding the end cap and having to start again.
Once you have that all done, replace the other end cap and ensure that it is correctly oriented as with the brush end cap. The metal body has a cut out which acts as a slot for the tab on the plastic end caps. The plastic tab for the brush end cap is behind the connector where the 2 wires from it's little pig tail loom are attached.
Once you have both end caps correctly seated, you can use a solid screw driver to press down the 4 tabs holding each en cap.
So, after all the above, and with all the circuit checks, I reconnected the motor to the seat power supply, activated the seat switch button, and it ran beautifully in both directions. I disconnected it, and re-fitted it to the seat before doing a final test to ensure the lift mechanism was working smoothly too.
The end result was a success. A fully operational seat again.
"Normal is overrated"
Image

Z3 Upgrades and Additions

Fender2004
Joined: Fri 14 Aug, 2009 11:24
Posts: 888

  Z3 roadster 2.8
Location: Houghton-Le-Spring

Re: Seat motors

Post by Fender2004 » Sat 27 Oct, 2018 16:28

Great write up, last time I checked my seat motors were ok, so I hope I don’t have to do this for a while. :D
Image

DC
Joined: Tue 15 Sep, 2009 18:31
Posts: 567

  Z3 roadster 1.9
Location: Inverness-shire

Re: Seat motors

Post by DC » Sun 28 Oct, 2018 10:33

Very nice and useful write up.
Dave.
Dave. 1998 Arctic Silver Z3 M44 1.9 Automatic

User avatar
Gazza
Site Admin
Joined: Tue 04 Oct, 2005 21:58
Posts: 9343

  M roadster S54
Location: Romford Essex

Re: Seat motors

Post by Gazza » Sun 28 Oct, 2018 19:46

Agreed, great write up as usual.

Moved to the Z3 Knowledge base.
Gazza

"Understeer is when you hit the wall with the front of the car, oversteer is when you hit the wall with the rear of the car. Horsepower is how fast you hit the wall and torque is how far you take the wall with you"

S54 M roadster Image, BMW Z1, BMW M3 CSL, Z4M Coupe
ImageImage

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest