Brake/reversing lights not working

International forum for all Z1 enthusiasts
Post Reply
User avatar
bluejay
Joined: Fri 16 Jan, 2004 13:40
Posts: 250

  Z1 roadster

Brake/reversing lights not working

Post by bluejay »

Recently noticed that the brake and reversing lights are not working. Due to covid not driving much…

I checked bulbs and fuses all good,….

Are these lights operated through a relay? If so anyone know which relay(s) and where they are located???

Thanks
Robert
User avatar
Stoertie
Joined: Fri 04 Jun, 2004 05:52
Posts: 333

  Z1 roadster
Location: near by Hamburg
Contact:

Re: Brake/reversing lights not working

Post by Stoertie »

Hi Robert,

there are no relays for reverse and breaking light. That fault is strange, because the wiring of breaking light and rear light are, with the exception of the ground connection, total different.

Does the problem happend on both sides?

I think it may be a problem of the connection from ground to the connector for the rear lights. But it's a little bit strange that the other lights are working.

regards
Michael
Men of steel driving cars of plastic! :-D

Sorry, for my poor english... schooltime is already a few years ago, but I try to do my very best! :-D

If you like, please visit Z1-Nordlichter / Leather Care / Roadster-Fashion.de

I believe I can fly... *lalala* Image
User avatar
bluejay
Joined: Fri 16 Jan, 2004 13:40
Posts: 250

  Z1 roadster

Re: Brake/reversing lights not working

Post by bluejay »

I checked the reverse light switch it was working fine,…

I a, thinking grounding too,.. the rear panel was removed this summer, maybe something loosened there…

Just need time and weather window to work on the car….
User avatar
Stoertie
Joined: Fri 04 Jun, 2004 05:52
Posts: 333

  Z1 roadster
Location: near by Hamburg
Contact:

Re: Brake/reversing lights not working

Post by Stoertie »

Is it only at one side or at both sides?

Have a look to the contacts inside the connector to the rear light. I think they used the same as inside the connector below the intake and these contacts are more and more weak.
If the contacts are black, there is a very high resistance. Then you hhave to change the contacts inside the connector. ;)
Men of steel driving cars of plastic! :-D

Sorry, for my poor english... schooltime is already a few years ago, but I try to do my very best! :-D

If you like, please visit Z1-Nordlichter / Leather Care / Roadster-Fashion.de

I believe I can fly... *lalala* Image
User avatar
bluejay
Joined: Fri 16 Jan, 2004 13:40
Posts: 250

  Z1 roadster

Re: Brake/reversing lights not working

Post by bluejay »

Ground is not the problem, the rear unit has a common ground from where the lights are “fed”….

Maybe a good clean with contact spray will help…

It is vey odd…

There are 8 points but have no diagram which connects to which light, anyone can help me with this?

Robert
User avatar
Stoertie
Joined: Fri 04 Jun, 2004 05:52
Posts: 333

  Z1 roadster
Location: near by Hamburg
Contact:

Re: Brake/reversing lights not working

Post by Stoertie »

Hi Robert,

here comes the pinning:

Connectors:
X10 – Rear Left
X11 – Rear Right

Pinning (same in both sides):
1 = Rear light
2 = Breaking light
4 = Indicator light
5 = Reversing light
6 = Rear fog light
7 = Ground

Nearby the contacts there should be small number marks in the plastic. ;)

Cleaning the contacts will only work for a very short time. The (female) contacts inside the connector are silver plated, when they are black oxidised and you clean the black layer away, you have nacked copper surface and that will oxidse very fast and you have the same problem again.
Only changing the contacts will help for the next 30 years.
I just have had that problem with the connector below the intake manifold. These bad contacts made the engine running very bad after the first cold start of the day. Cleaning didn't help but after changing the all contacts (a very nasty occupation :x ) the engine runs perfect after a cold start.

The contacst inside the connector should be the part number: 61 13 1 376 202 called: "Rundsteckhülse 2.5" and cost 1.31 Euro (at this page https://www.leebmann24.de/bmw-ersatztei ... bt=12_0345 the part no. 3)

Regards
Michael
Last edited by Stoertie on Tue 21 Dec, 2021 19:36, edited 1 time in total.
Men of steel driving cars of plastic! :-D

Sorry, for my poor english... schooltime is already a few years ago, but I try to do my very best! :-D

If you like, please visit Z1-Nordlichter / Leather Care / Roadster-Fashion.de

I believe I can fly... *lalala* Image
User avatar
bluejay
Joined: Fri 16 Jan, 2004 13:40
Posts: 250

  Z1 roadster

Re: Brake/reversing lights not working

Post by bluejay »

That sucks…..

Because the whole of the connector is moulded/glued up… to replace these pins I am going to need to break things open by the looks of it…

Bugger it…

Thanks for your explanation,…

How likely is it that this happens at the same time for the same lights each side…. ????

Robert
User avatar
Stoertie
Joined: Fri 04 Jun, 2004 05:52
Posts: 333

  Z1 roadster
Location: near by Hamburg
Contact:

Re: Brake/reversing lights not working

Post by Stoertie »

That's right, the connector at the rear light is glued, but the connector at the cable has a rubber cap and it should be possible to pin out the contacts.
There are several tool sets available at ebay for pinning out contacts from the different housings.. ;-) But check the voltage and the ground at the connector mounted at the cable first. ;-)
In the very worsed case you can take the whole connector from the link above and make nnd make a newnconnection to the rear light too. There the male connector is only fixed at the rear light housing. All cables are outside of the rear light. Should be no problem.

Regards
Michael
Men of steel driving cars of plastic! :-D

Sorry, for my poor english... schooltime is already a few years ago, but I try to do my very best! :-D

If you like, please visit Z1-Nordlichter / Leather Care / Roadster-Fashion.de

I believe I can fly... *lalala* Image
User avatar
bluejay
Joined: Fri 16 Jan, 2004 13:40
Posts: 250

  Z1 roadster

Re: Brake/reversing lights not working

Post by bluejay »

Thanks for your help Michael,…

Except it is freezing cold at the moment!!! Hahahaha

Going to check voltages when defrosted abit

Robert
User avatar
bluejay
Joined: Fri 16 Jan, 2004 13:40
Posts: 250

  Z1 roadster

Re: Brake/reversing lights not working

Post by bluejay »

What is pin 3?

It seems this is the ground for the brake and rear light?

With pin 7 the grnd for the other lights??

Oh,… if only i had a wiring diagram….

Robert
User avatar
Stoertie
Joined: Fri 04 Jun, 2004 05:52
Posts: 333

  Z1 roadster
Location: near by Hamburg
Contact:

Re: Brake/reversing lights not working

Post by Stoertie »

Hi Robert,

it's possible that 3 is also a ground.

Please check it reverse...
From the bulb socket to the pins inside the glued connector at rear light. If Pin 3 is the ground for reverse/brake there must be 0 ohms between the pin and one of the connectors at the bulb sockets of the reverse and/or brake light. ;-)

Regards and a happy new year
Michael
Men of steel driving cars of plastic! :-D

Sorry, for my poor english... schooltime is already a few years ago, but I try to do my very best! :-D

If you like, please visit Z1-Nordlichter / Leather Care / Roadster-Fashion.de

I believe I can fly... *lalala* Image
User avatar
bluejay
Joined: Fri 16 Jan, 2004 13:40
Posts: 250

  Z1 roadster

Re: Brake/reversing lights not working

Post by bluejay »

Each bulb has a brown and grey wire,…

The wires for the rear and brake ground to pin 3 ( brown), the reverse light, indicator and possible fog light seem to ground to pin 7…

I suspect there is a cable break inside the body somewhere, perhaps when the body panels where of this summer for the door repair…

Been in contact already with RKV to get the car collected…

Robert
User avatar
Stoertie
Joined: Fri 04 Jun, 2004 05:52
Posts: 333

  Z1 roadster
Location: near by Hamburg
Contact:

Re: Brake/reversing lights not working

Post by Stoertie »

Who has taken off the rear wing? RKV? - Than it should be a repaair for free, otherwise you can try to open the cap of the connector at the cable, check wich one (7 or 3) has no connection to ground, make a new connection from that pin to the chassis. (It's not perfect but it will work :D )
Men of steel driving cars of plastic! :-D

Sorry, for my poor english... schooltime is already a few years ago, but I try to do my very best! :-D

If you like, please visit Z1-Nordlichter / Leather Care / Roadster-Fashion.de

I believe I can fly... *lalala* Image
User avatar
bluejay
Joined: Fri 16 Jan, 2004 13:40
Posts: 250

  Z1 roadster

Re: Brake/reversing lights not working

Post by bluejay »

Ok, dropped the Z1 of at a local garage, it turned out it was the switches after all!! :facepalm:

Both replaced and working again...
User avatar
Stoertie
Joined: Fri 04 Jun, 2004 05:52
Posts: 333

  Z1 roadster
Location: near by Hamburg
Contact:

Re: Brake/reversing lights not working

Post by Stoertie »

Hi Robert,

very strange! - Two switches at the same time...

Regards
Michael
Men of steel driving cars of plastic! :-D

Sorry, for my poor english... schooltime is already a few years ago, but I try to do my very best! :-D

If you like, please visit Z1-Nordlichter / Leather Care / Roadster-Fashion.de

I believe I can fly... *lalala* Image
User avatar
bluejay
Joined: Fri 16 Jan, 2004 13:40
Posts: 250

  Z1 roadster

Re: Brake/reversing lights not working

Post by bluejay »

Well they are 32 years old!!

Bound to happen, seems my fog lights switch is also not working properly, slightly seized!!

luckily it never ends!!

Robert
Post Reply