oil pressure light

UK forum for general and technical discussion about the Z3 roadster

Moderator: Gazza

Post Reply
Jim Z3
Joined: Thu 23 Jan, 2014 22:18
Posts: 5

  Z3 roadster 3.0i

oil pressure light

Post by Jim Z3 » Tue 19 Jul, 2016 22:21

3.0i z3 oil pressure light slow to go out in mornings, Have changed o rings and filter but no better ? :head:

Del
Joined: Sat 19 Nov, 2011 18:35
Posts: 2127

  Z3 roadster 1.9

Re: oil pressure light

Post by Del » Tue 19 Jul, 2016 23:11

With oil pressure problems I would expect to see it worsen with hot (thinner) oil and at idle revs (flashing light). Assuming your oil is nice and fresh (no old sludge), correct viscosity and the oil filter is working properly (not old, blocked or compressed), my initial guess would be a faulty oil pressure switch. It is quite a simple job for a garage to check oil pressure via the same connection – it may just be case of a faulty switch – on some cars e.g. certain Vauxhalls, faulty switches are quite common. Good makes are something like OE of FAI.

NZ00Z3
Joined: Thu 23 Jun, 2016 02:26
Posts: 68

  Z3 roadster 3.0i

Re: oil pressure light

Post by NZ00Z3 » Wed 20 Jul, 2016 05:57

Hi

Follow this thread and links through to the end. It may be your problem. Oil squirters towards the pistons was the end result.

http://www.bimmerforums.com/forum/showt ... -Oil-Light

Hope this helps

Regards

Muzz

Jim Z3
Joined: Thu 23 Jan, 2014 22:18
Posts: 5

  Z3 roadster 3.0i

Re: oil pressure light

Post by Jim Z3 » Wed 20 Jul, 2016 11:44

oil light only slow when been stood awhile not at tick over even after a long motorway drive, more like filter draining ?

User avatar
Brian H
Joined: Tue 16 Dec, 2008 19:55
Posts: 2503

  Z3 roadster 3.0i

Re: oil pressure light

Post by Brian H » Wed 20 Jul, 2016 12:45

Is the light slow to go out once you have started the car or when you turn the car off?

Jim Z3
Joined: Thu 23 Jan, 2014 22:18
Posts: 5

  Z3 roadster 3.0i

Re: oil pressure light

Post by Jim Z3 » Wed 20 Jul, 2016 13:06

when started after stood a hour or more rest of time goes out instantly

Del
Joined: Sat 19 Nov, 2011 18:35
Posts: 2127

  Z3 roadster 1.9

Re: oil pressure light

Post by Del » Wed 20 Jul, 2016 22:31

Jim Z3 wrote:more like filter draining ?
I agree with your line of thought. If you have low oil pressure due to engine wear, the light would blink more on a hot engine and typically at tick-over revs. The fact that this is only happening after the car has stood a while when the oil will be cold or cool, doesn’t tend to point to engine wear or faulty oil pump – I haven’t heard of many oil pumps failing on these cars. If oil was failing to get to the upper engine, the hydraulic valves wouldn’t be working properly which would cause problems starting and loud/ticking.

Like you, I wonder whether oil is slowly leaking back through the “non-return valve” at the back of the oil filter housing. When I replaced the housing gasket on my 1.9, the helpful BMW parts staff recommended replacing the valve and o-ring at the same time, hinting that they sold quite a lot of the complete kit i.e. gasket and valve/spring/o-ring – from memory it was only a few pounds for the 1.9 – the mechanism looks a little different on the 6-pot engine (see link below)

http://forum.e46fanatics.com/showthread.php?t=900804

Jim Z3
Joined: Thu 23 Jan, 2014 22:18
Posts: 5

  Z3 roadster 3.0i

Re: oil pressure light

Post by Jim Z3 » Fri 22 Jul, 2016 13:27

Thanks Del , Called BMW dealer only comes as a new housing £132.70 + vat , Can't think it can be anything but the non return valve .

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests