Cruise retrofitted!

UK forum for general and technical discussion about the Z3 roadster
Post Reply
Grello
Joined: Thu 19 May, 2016 07:00
Posts: 37

  Z3 roadster 2.2i

Cruise retrofitted!

Post by Grello »

Just finished the cruise control retrofit. About an hour for me too and works a treat straight "out of the box". A fantastic and straightforward add-on which will take some of the strain away on our upcoming trip to Bavaria.

If I can do it, so can anyone with a little bit of DIY.

Strut brace has arrived today, too. Much excitement!

G
Grello

2002 Z3 2.2 M Sport, East Sussex
User avatar
motco
Joined: Tue 18 Aug, 2009 18:12
Posts: 715

  Z3 roadster 2.2i

Re: Cruise retrofitted!

Post by motco »

Yes, it's easy of the fly-by-wire models. The hardest part is finding the hidden connector taped to the loom. Mine, also on a 2.2i, occasionally doesn't respond to a command, but after a stop and start it usually does.
gookah
Z Register member
Joined: Thu 07 Aug, 2008 09:51
Posts: 2737

  Z3 roadster 2.8

Re: Cruise retrofitted!

Post by gookah »

yes mine does that on occasion... works fine for 99% then an odd occasion it wont activate. I have to switch off and back on again...
Image

Z3 2.8 Progress Journal (Mine)
Z3 1.9 Sport Progress Journal (Wifey's)

I have an element of 'M-styling' on my car, If that's a good enough reason for the manufacturers to adorn a 320 with the M badge, then its certainly a good enough reason for me..
User avatar
lightning
Joined: Tue 27 Nov, 2007 08:15
Posts: 818

  Z3 roadster 3.0i
Location: Stockport

Re: Cruise retrofitted!

Post by lightning »

Fitting cruise control is easy on the later Z3 with electronic throttle. It took me less than an hour to do mine and as above it worked perfectly.
neilb62
Joined: Sun 24 May, 2020 13:16
Posts: 14

  Z3 roadster 3.0i

Re: Cruise retrofitted!

Post by neilb62 »

Hi all, sorry to drag up an old thread but where the heck is that connector hidden, been under there about two hours now.
Thanks.
Neil.


Sent from my iPhone using Tapatalk
User avatar
Robert T
Site Admin
Joined: Mon 12 Jun, 2006 10:35
Posts: 10126

  Z3 roadster 1.9
Location: Cheshire

Re: Cruise retrofitted!

Post by Robert T »

Hi Neil,
Some pics in this thread: viewtopic.php?t=42906
Cheers R.

Sent from my SM-G960F using Tapatalk

Arctic Silver '99 Z3 1.9 & Black '59 Frogeye 1275cc
Image
neilb62
Joined: Sun 24 May, 2020 13:16
Posts: 14

  Z3 roadster 3.0i

Re: Cruise retrofitted!

Post by neilb62 »

Hi, been through that thread before but thanks for the reminder.
A mate found his above the pedals, going to check there later.


Sent from my iPhone using Tapatalk
neilb62
Joined: Sun 24 May, 2020 13:16
Posts: 14

  Z3 roadster 3.0i

Re: Cruise retrofitted!

Post by neilb62 »

Another hour under there and no sign of it, surely this can’t be the only car built without the lead? [emoji31]
Image
Image
Image
Image


Sent from my iPhone using Tapatalk
neilb62
Joined: Sun 24 May, 2020 13:16
Posts: 14

  Z3 roadster 3.0i

Re: Cruise retrofitted!

Post by neilb62 »

And as I posted that I found it!
It was on top of the main lion, had to cut it free!

Image


Sent from my iPhone using Tapatalk
neilb62
Joined: Sun 24 May, 2020 13:16
Posts: 14

  Z3 roadster 3.0i

Re: Cruise retrofitted!

Post by neilb62 »

Lion? Loom... [emoji1787]


Sent from my iPhone using Tapatalk
User avatar
motco
Joined: Tue 18 Aug, 2009 18:12
Posts: 715

  Z3 roadster 2.2i

Re: Cruise retrofitted!

Post by motco »

I was about to reply to the effect that it is an absolute pig to find when I read your final post. :D
neilb62
Joined: Sun 24 May, 2020 13:16
Posts: 14

  Z3 roadster 3.0i

Re: Cruise retrofitted!

Post by neilb62 »

motco wrote:I was about to reply to the effect that it is an absolute pig to find when I read your final post. :D
If you look at the thick loom by the bracket with the gold nut, it was inside there [emoji15]


Sent from my iPhone using Tapatalk
User avatar
motco
Joined: Tue 18 Aug, 2009 18:12
Posts: 715

  Z3 roadster 2.2i

Re: Cruise retrofitted!

Post by motco »

neilb62 wrote: Fri 16 Apr, 2021 11:05
motco wrote:I was about to reply to the effect that it is an absolute pig to find when I read your final post. :D
If you look at the thick loom by the bracket with the gold nut, it was inside there [emoji15]


Sent from my iPhone using Tapatalk
That sounds like the long shaggy dog story joke that ends with "...and when he stood up his arse fell off!" :P
neilb62
Joined: Sun 24 May, 2020 13:16
Posts: 14

  Z3 roadster 3.0i

Re: Cruise retrofitted!

Post by neilb62 »

Having been under there for hours it nearly did! [emoji1787]


Sent from my iPhone using Tapatalk
neilb62
Joined: Sun 24 May, 2020 13:16
Posts: 14

  Z3 roadster 3.0i

Re: Cruise retrofitted!

Post by neilb62 »

Okay, switch and interface fitted and it doesn’t work.
Guess I’ll need a clutch switch with it being manual?


Sent from my iPhone using Tapatalk
neilb62
Joined: Sun 24 May, 2020 13:16
Posts: 14

  Z3 roadster 3.0i

Re: Cruise retrofitted!

Post by neilb62 »

Also looks like I may have the wrong column switch too, mines two wire, I need four wires for a Z!


Sent from my iPhone using Tapatalk
User avatar
motco
Joined: Tue 18 Aug, 2009 18:12
Posts: 715

  Z3 roadster 2.2i

Re: Cruise retrofitted!

Post by motco »

I did mine a while ago and I didn't need a clutch switch. Is your car fly-by-wire or cable throttle? Mine is a very late 2.2i with FbW and it's a simple fitting - once that damned plug is found! Can't recall the details of the connections now though, sorry.
neilb62
Joined: Sun 24 May, 2020 13:16
Posts: 14

  Z3 roadster 3.0i

Re: Cruise retrofitted!

Post by neilb62 »

motco wrote:I did mine a while ago and I didn't need a clutch switch. Is your car fly-by-wire or cable throttle? Mine is a very late 2.2i with FbW and it's a simple fitting - once that damned plug is found! Can't recall the details of the connections now though, sorry.
Mine is fly-by-wire (3.0 M54 engine) my money is on the stalk-switch being wrong.


Sent from my iPhone using Tapatalk
neilb62
Joined: Sun 24 May, 2020 13:16
Posts: 14

  Z3 roadster 3.0i

Re: Cruise retrofitted!

Post by neilb62 »

Been back under the dash today to fit a clutch switch I won on eBay to find it already has one.....

Oh well I have a spare switch now... :D

Stalk switch is trundling its way from Germany....
Post Reply