ABS and ASC lights on

UK forum for general and technical discussion about the Z3 roadster

Moderator: Gazza

Post Reply
User avatar
colb
Joined: Sat 05 May, 2012 23:46
Posts: 640

  Z3 roadster 1.8 TU
Location: Newport South Wales UK

ABS and ASC lights on

Post by colb » Sat 24 Mar, 2018 23:44

Went to start the Z this afternoon only to find it had a flat battery. Used a start and charge booster to jump start it using the battery terminals. Started right up but ABS and ASC lights on the dashboard. Broke out the laptop and fired up INPA after some difficulty with the laptop which also had a dead battery. Running it on mains I had problems seeing the ABS module in the E36 Chassis module, it couldnt connect to the module. Kept trying and evetually got it to display. Had a look through but couldn't find any error codes set. Ran a test on the pump and it ran fine when selected. I then noticed that both ABS and ASC lights had gone out.
Prior to this I had driven the car up and down the road a few times to see if the lights would go out, thats why I resorted to using INPA. Checked all the fuses and relays, all appeared good, took them out and re seated them.
Shortly after getting the lights out the laptop died, going to look for a replacement to put the software on.

I think the cause of the lights setting may have been due to the boot lid being left unlatched and the boot light draining the battery over the 2 weeks I had left it. Using the booster to start it might have spiked the voltage to the control unit setting the lights.
Have removed the bulb from the boot light as the battery charger is sitting in there with the mains lead running out of the boot so cannot close it fully.
Car is on Sorn so can't take it for an extended run until I tax it at the start of April.

Any thoughts on this?
Colb
1999 BMW 1.8 Z3
1998 Honda Deauville NT650V

andy & fonz
Joined: Tue 28 Jul, 2015 18:35
Posts: 64

  Z3 roadster 2.2i

Re: ABS and ASC lights on

Post by andy & fonz » Sun 25 Mar, 2018 10:26

Hi
Had the same thing on mine last year, up and down drive lights on sorted it by fitting new sensors on both front wheels although this did show up on my c110 reader has a fault, put it down to muck and rust contaminating the sensors and inactivaty compounding the problem

therealdb1
Joined: Tue 25 Jun, 2013 22:47
Posts: 263

  Z3 roadster 2.0

Re: ABS and ASC lights on

Post by therealdb1 » Sun 25 Mar, 2018 23:44

My car used to do that occasionally particularly if it had not been used in a while. It seemed to clear itself after a heat cycle so I put it down to damp/condensation in one of the connectors somewhere. When the car was in regular use it never seemed to be a problem.

User avatar
colb
Joined: Sat 05 May, 2012 23:46
Posts: 640

  Z3 roadster 1.8 TU
Location: Newport South Wales UK

Re: ABS and ASC lights on

Post by colb » Mon 02 Apr, 2018 20:39

Replacement Laptop sourced with Windows 7 Proffessional on it, loaded the Inpa software then had two days of messing about getting it yto work. First problem was no menu displayed just blank screen and buttons. Found a fix for this on the web and evetually after deleting some windows drivers and adding a missing file got the menu to display. Tried it out on the car and it connects and displayes some of the generic live data but will not open the specific E36 Engine or Chassis modules for some reason.
Much more tinkering required I think to get it running right as it was on the old laptop.
Colb
1999 BMW 1.8 Z3
1998 Honda Deauville NT650V

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests