P0414 Error code

UK forum for general and technical discussion about the Z3 roadster

Moderator: Gazza

Post Reply
z3steve
Joined: Thu 03 Feb, 2011 23:01
Posts: 155

  Z3 roadster 2.2i
Location: Tunbridge Wells

P0414 Error code

Post by z3steve »

Hi all not been here for a while. I got rid of my 2.0 and bought a 2.2i :) Anyway today, several times today whilst cruising at a steady 70, the power just drops and then comes back. Very intermittent, did it at various speeds after that. Plugged it in and got P0414 which is to do with the secondary air pump, but that has been removed. Now I know codes can sometimes be describing something that is actually irrelevant to the problem, just wondered if anyone has an idea of the cause and fix? No lights on the dash on startup btw

Cheers
Steve

User avatar
motco
Joined: Tue 18 Aug, 2009 18:12
Posts: 704

  Z3 roadster 2.2i

Re: P0414 Error code

Post by motco »


mrscalex
Joined: Fri 13 Mar, 2015 09:14
Posts: 898

  Z3 roadster 1.9

Re: P0414 Error code

Post by mrscalex »

I have a 2.2 that persistently reports a secondary air pump error. Despite never having been fitted with one. It doesn't affect the performance of the car in any way.
ImageImage
2001 Z3 2.2 Topaz Blue (Trudy) - Keeper rebuilt from a write-off
2002 Z3 2.2 Titan Silver (Cookies) - Keeper rebuilt having been bought with a seized engine
2002 Z3 3.0 Sapphire Black (Peanut) - Keeper awaiting rebuilding having been bought as an abandoned project
Plus Willy, Kodak & Maycee - All 2.2 Sport projects. Yes, 6 is a lot of Z3s :)
Always happy to try and help with spares :)

z3steve
Joined: Thu 03 Feb, 2011 23:01
Posts: 155

  Z3 roadster 2.2i
Location: Tunbridge Wells

Re: P0414 Error code

Post by z3steve »

Hi thanks for the replies, I can only assume the error code has nothing to do with the problem I had. I delete the 0414 code and it always instantly comes back even without starting the car. Will totally ignore that code in future.
Went out for a long drive this morning and couldn’t get the fault / misfire to reoccur, and nothing else came up on the scan. Will just wait and see if it happens again and go from there. Not gonna start throwing money at sensors etc just yet!

Thanks again
Steve

mrscalex
Joined: Fri 13 Mar, 2015 09:14
Posts: 898

  Z3 roadster 1.9

Re: P0414 Error code

Post by mrscalex »

z3steve wrote:
Fri 12 Jun, 2020 12:43
Hi thanks for the replies, I can only assume the error code has nothing to do with the problem I had. I delete the 0414 code and it always instantly comes back even without starting the car. Will totally ignore that code in future.
Went out for a long drive this morning and couldn’t get the fault / misfire to reoccur, and nothing else came up on the scan. Will just wait and see if it happens again and go from there. Not gonna start throwing money at sensors etc just yet!

Thanks again
Steve
I'm not normally for ignoring error codes. But personal experience of this one suggests it's the right thing to do.
ImageImage
2001 Z3 2.2 Topaz Blue (Trudy) - Keeper rebuilt from a write-off
2002 Z3 2.2 Titan Silver (Cookies) - Keeper rebuilt having been bought with a seized engine
2002 Z3 3.0 Sapphire Black (Peanut) - Keeper awaiting rebuilding having been bought as an abandoned project
Plus Willy, Kodak & Maycee - All 2.2 Sport projects. Yes, 6 is a lot of Z3s :)
Always happy to try and help with spares :)

Post Reply