Air Con, cleaned and re gassed stops working?

UK forum for general and technical discussion about the Z3 roadster
Post Reply
Warrior
Joined: Tue 11 May, 2010 10:02
Posts: 486

  Z3 roadster 3.0i

Air Con, cleaned and re gassed stops working?

Post by Warrior »

Having got used to running with no aircon for some while I treated myself to a special clean and re-gas a couple of months ago. All worked fine until the last couple of trips, nothing....no cold air at all?

Any ideas as to what the problem may be?
User avatar
Robert T
Site Admin
Joined: Mon 12 Jun, 2006 10:35
Posts: 10147

  Z3 roadster 1.9
Location: Cheshire

Re: Air Con, cleaned and re gassed stops working?

Post by Robert T »

There can only be a limited number of things it can be. First guess is that the system has a leak and the gas has escaped. If not that then either the compressor has failed or the electrical side that turns it on and off has failed. Might be worth checking fuses for the latter.

Cheers R.

Sent from my SM-G991B using Tapatalk

Arctic Silver '99 Z3 1.9 & Black '59 Frogeye 1275cc
Image
Warrior
Joined: Tue 11 May, 2010 10:02
Posts: 486

  Z3 roadster 3.0i

Re: Air Con, cleaned and re gassed stops working?

Post by Warrior »

Thanks Robert. Will check the fuse box properly.....

UPDATE: Double checked fuses and all look good to me.
137699
Joined: Wed 04 Mar, 2020 21:40
Posts: 28

  M coupe S50

Re: Air Con, cleaned and re gassed stops working?

Post by 137699 »

If the system needed regassing then unless it's due to some work that required depressurising the system, the only other reason it would need regassing is if it's leaked out.
Usually the leak will be from the condensor rad which is probably old/holed/rotten.

Get the system regassed with dye in it - wait for it to leak, then get it up on a ramp with a UV lamp and look for telltale signs of seepage to see where your issue lies.
petecossie
Joined: Wed 11 Apr, 2007 13:13
Posts: 157

  M coupe S50
Location: Billingham

Re: Air Con, cleaned and re gassed stops working?

Post by petecossie »

My wife's Golf GT needed regasing after failing to give any cool air during the real hot spell earlier in the year. Used one of the franchised tyre depots, charged me £55 to regas. A week later back to no cold air, went back to complain. Reply was, "Oh we need the travelling expert to have a look, it will cost £60 plus what ever needs fixing. No thanks.
Went to a little local garage to have the system checked again. £50 plus £25 if there was a leak and sealant was needed. When I picked it up just £50 as no leaks found. Real cold air, you could hang meat up inside the car. I think the guys at the franchise depot didn't do the job properly for sure, as the A/C in the Golf is still icy cold 7 weeks on!!
May not help you directly but does show that sometimes the so called "experts" can get it wrong.
Pete C

2000 Z3M Coupe - Cosmos Black Metallic/Black Interior.

Previous BMWs
2003 E46 M3 6 speed manual - Carbon Black/Black Interior.
2000 Z3M Coupe - Cosmos Black/Black Interior
1986 M635
1985 E28 M5
1983 E28 528i Alpina
Post Reply