P0340 Fault i cant get rid of!!

UK forum for general and technical discussion about the Z3 roadster
Post Reply
4wheels
Joined: Sat 24 Sep, 2016 19:42
Posts: 83

  Z3 roadster 3.0i

P0340 Fault i cant get rid of!!

Post by 4wheels »

My cars been off the road a little bit, it had a fault after I went over a pot hole!
whilst trying to find it i changed quite a few bits.
idle valve, (it didnt move)
crankshaft sensor (its old)
exhaust camshaft sensor (it was old )
inlet camshaft sensor (tried 3 now)
camshaft cover seal, definately was leaky
cleaned all the gunk out of many tubes, PCV valve,
vanos service (new seals, they were defo old)
crank case oil breather, lots of the pipes looked iffy
new injector orings
feul filter
vac lines, and caps on the manifold.
brake lines.
not all related to the problem of course.. but all needed to be done

so, i just cant get rid of the P0340 fault,
i've changed the plug the sensor plugs into wiring, have continuity from the connector all the way to the ecu plug. the sensor works... the yellow wire has a signal on it.
slightly oddly... i'm not 100% convinced i have the vac lines correct... there is one from the fuel filter, one to the fuse box? one to the F piece after the MAF, and theres also a big round vac thing.. theres 2 small holes and 1 big hole on the back of the manifold,... all have vac. and before the changes above the cap on the big hole wasnt there any more! treid various ways... but not sure which is right?

open to all suggestions... nothing is stupid!
LaRy
Joined: Mon 12 Nov, 2018 17:47
Posts: 152

  Z3 roadster 2.8

Re: P0340 Fault i cant get rid of!!

Post by LaRy »

Please tell us what kind of Z3 you have. What year, engine type, gear box......
But in most cases it is the camshaft position sensor
4wheels
Joined: Sat 24 Sep, 2016 19:42
Posts: 83

  Z3 roadster 3.0i

Re: P0340 Fault i cant get rid of!!

Post by 4wheels »

its a 2000, 3.0i manual.. any ideas?
LaRy
Joined: Mon 12 Nov, 2018 17:47
Posts: 152

  Z3 roadster 2.8

Re: P0340 Fault i cant get rid of!!

Post by LaRy »

With P0340 the crankshaft sensor is no 1 to change, not the inlet or outlet camshaft sensors. Those are no 2 to be changed.
Another thing mentioned in the Swedish Z3-forum mentioned several times, you cannot by some cheap sensors, it does only exist 3 brands that will work for sure: BMW original, Bosch or VDO-Siemens.
Post Reply