Strange noise and battery draining when car is switched off

UK forum for general and technical discussion about the Z4 roadster and Z4 Coupe

Moderator: Gazza

Post Reply
hotred
Joined: Sun 15 Mar, 2009 18:39
Posts: 144

  Z3 roadster 3.0i
Location: barnston
Contact:

Strange noise and battery draining when car is switched off

Post by hotred »

Hi All,
Haven't posted on Zroadster for ages, so hello again to everyone.
I now drive a 2010 Z4 sDrive 3.0i or at least was, I have recently advertised car for sale and after nearly 4 years of faultless ownership she decides to develop a fault and I wondered if any of you brain boxes on hear may be able to help.
When I switch off the car and lock it up a strange electrical buzzing/whirring sound is coming from the front of the engine, it sounds almost like the central locking when you lock the car but more faint, it goes of every few seconds and only stops when car unlocked and key in ignition.
As this is causing a parasitic drain on the battery and when I open the car the windows dont drop, they do when key goes in ignition.
I can't pinpoint exactly where noise comes from but it is to left or right of radiator and is definitely at the front end of the engine compartment.
With the exception of the windows not dropping till key goes in and the drain on battery the car seems to have no further issues.
Can any help with possible ideas, sods law these things only happen when you are selling a car, and I have two definite buyers and need to get to bottom of this fault, BMW are really busy so no chance of a quick visit and diagnosis.
Thanks

Post Reply