Tape/cd players says “wait”

UK forum for general and technical discussion about the Z3 roadster

Moderator: Gazza

Post Reply
Pele no2
Joined: Tue 20 Feb, 2018 21:21
Posts: 12

  Z3 roadster 1.9i

Tape/cd players says “wait”

Post by Pele no2 » Fri 11 Oct, 2019 13:52

Hi,
I’m enquiring if anybody has experienced this. It’s my dads 2002 2.2 z3, that he has just bought back from the guy he sold it to a couple of years ago.
It still has the original tape/6 stacker CD player in the boot.
He has the code for the stereo, but when you switch it on it just displays “wait”, even after leaving it for over a week.
I tried the code, but nothing happens to the display. I’m not sure if the last owner let the battery go flat, and maybe that’s the cause.
Anybody had this happen to them?

Ps. My dads 85 and although he can still run a normal car and a sports car his computer skills haven’t kept up with today’s demand..... :lol:

Cheers, Mark.

RobTFC
Joined: Mon 29 Dec, 2014 14:23
Posts: 38

  M roadster S50

Re: Tape/cd players says “wait”

Post by RobTFC » Fri 11 Oct, 2019 14:21

Hi Mark,

Can you confirm whether the wording is simply "WAIT" or "CODE WAIT"? I don't think just "WAIT" on its own is a valid state, and iirc the maximum wait time is supposed to be 90 minutes.

Maybe the unit itself is in a wierd state? Try disconnecting it from the car/power for a day and trying again if you haven't already. I have seen some really odd behaviours with these radios, such as one particular unit which would slow down (as in button presses would be missed or heavily delayed) when a CD changer was connected.

In the worst case, the radio is goosed, but the standard tape players are not hard to come by, in fact I have a spare somewhere (with a code!) if you need it as I replaced one of mine with an OEM front loading player.

Pele no2
Joined: Tue 20 Feb, 2018 21:21
Posts: 12

  Z3 roadster 1.9i

Re: Tape/cd players says “wait”

Post by Pele no2 » Fri 11 Oct, 2019 19:39

Hi Rob,
I’m sure it said just wait, when I saw it last week. I can ask him, as I live nearly 200 miles from my dad!
I will get him to disconnect the battery and retry it. Alternatively I will send you a mail if it doesn’t work, as I know he wants the unit to work.
What do you want for your tape unit?

Regards, Mark.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests